1

Topic: Ubuntu 10.04 kismet.conf Broadcom wireless card

I am using Ubuntu 10.04 64 bit and the wireless card on this is from Broadcom. I installed kismet as

aptitude install kismet

But when I run kismet I do not find any ncurses sort of interface as I expect give here

http://openmaniak.com/kismet_conf.php

and this is the error I get

Launching kismet_server: //usr/bin/kismet_server
Suid priv-dropping disabled.  This may not be secure.
No specific sources given to be enabled, all will be enabled.
Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
Enabling channel hopping.
Enabling channel splitting.
NOTICE: Disabling channel hopping, no enabled sources are able to
change channel.
Source 0 (addme): Opening none source interface none...
FATAL: Please configure at least one packet source.  Kismet will not
function if no packet sources are defined in kismet.conf or on the
command line.  Please read the README for more information about
configuring Kismet.
Kismet exiting.

I followed this guide

http://www.ubuntugeek.com/kismet-an-802-11-wireless-network-detector-sniffer-and-intrusion-detection-system.html#more-1776

how ever in kismet.conf I am not clear with following line

source=none,none,addme

as to what should I change this to.

lspci -vnn

shows

0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312
802.11b/g [14e4:4315] (rev 01)
Subsystem: Dell Device [1028:000c]
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at f69fc000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [40] Power Management version 3
Capabilities: [58] Vendor Specific Information <?>
Capabilities: [e8] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Capabilities: [d0] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting <?>
Capabilities: [13c] Virtual Channel <?>
Capabilities: [160] Device Serial Number
Capabilities: [16c] Power Budgeting <?>
Kernel driver in use: wl
Kernel modules: wl, ssb

and

iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11bg ESSID:"WIKUCD"
Mode:Managed Frequency:2.462 GHz Access Point: <00:43:92:21:H5:09>
Bit Rate=11 Mb/s Tx-Power:24 dBm
Retry min limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Managementmode:All packets received
Link Quality=1/5 Signal level=-81 dBm Noise level=-90 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:169 Invalid misc:0 Missed beacon:0

So what should I be putting in place of

source=none,none,addme

in kismet.conf.. With output I mentioned above ?

2

Re: Ubuntu 10.04 kismet.conf Broadcom wireless card

Tray this (but it pendent to installed driver)

source=bcm43xx,$iface,broadcom